Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: vBulletin does not recognize special characters

  1. #11
    Senior Member Oddity's Avatar
    Join Date
    Oct 2008
    Location
    Virginia Beach, VA
    Posts
    3,161
    Blog Entries
    1
    Quote Originally Posted by t8burst View Post
    Try pasting in as plain text or I gues on a mac it's "match style". It a problem with the character encoding

    I?ve been using an iPhone for posting here since they came out and haven?t ever had an issue until the past few weeks. Trying to nail down what changed and unless some backend update happened to the server/servers/cloud that hosts this site all I?ve got to go on is the recent iOS update. No info on character set included in the patch notes though.

    As far as I know, there isn?t a way to natively generate plain text on an iPhone. Maybe there?s an app for ?dat.

    What?s odd is that I can edit and save the quotes back into a post, and they also appear while previewing the post, it?s only during the initial submission and insertion into the database that the character encoding for quotes goes wrong.



    Anyone else using an iPhone on the latest iOS experiencing the same thing?

    ETA: Ok, looks like iOS 11.1.x has some Unicode text formatting bugs. There question marks appearing all over the internet in iOS 11.1 users posts. Apple rules. They say they fixed some Unicode bugs in 11.1.1 but some still exist, apparently.
    Last edited by Oddity; 11-14-2017 at 09:12 AM.
    "If you only know your side of an issue, you know nothing." -John Stuart Mill, On Liberty

    "Even what those with the greatest reputation for knowing it all claim to understand and defend are but opinions..." -Heraclitus, Fragments

  2. #12
    The new IOS is crap. I constantly have to restart my phone because it loses it mind when it can't find the network in my garage. As a work around I put it in airplane mode until I get outside the garage and back in coverage.

    Quote Originally Posted by Oddity View Post
    I?ve been using an iPhone for posting here since they came out and haven?t ever had an issue until the past few weeks. Trying to nail down what changed and unless some backend update happened to the server/servers/cloud that hosts this site all I?ve got to go on is the recent iOS update. No info on character set included in the patch notes though.

    As far as I know, there isn?t a way to natively generate plain text on an iPhone. Maybe there?s an app for ?dat.

    What?s odd is that I can edit and save the quotes back into a post, and they also appear while previewing the post, it?s only during the initial submission and insertion into the database that the character encoding for quotes goes wrong.



    Anyone else using an iPhone on the latest iOS experiencing the same thing?

    ETA: Ok, looks like iOS 11.1.x has some Unicode text formatting bugs. There question marks appearing all over the internet in iOS 11.1 users posts. Apple rules. They say they fixed some Unicode bugs in 11.1.1 but some still exist, apparently.

  3. #13
    Senior Member Oddity's Avatar
    Join Date
    Oct 2008
    Location
    Virginia Beach, VA
    Posts
    3,161
    Blog Entries
    1
    Quote Originally Posted by t8burst View Post
    The new IOS is crap. I constantly have to restart my phone because it loses it mind when it can't find the network in my garage. As a work around I put it in airplane mode until I get outside the garage and back in coverage.
    An update just dropped a few minutes ago, I wonder if it?s fixed....

    ???????????????

    ...sigh...
    "If you only know your side of an issue, you know nothing." -John Stuart Mill, On Liberty

    "Even what those with the greatest reputation for knowing it all claim to understand and defend are but opinions..." -Heraclitus, Fragments

  4. #14
    Senior Member
    Join Date
    Jun 2005
    Location
    East Bay/San Francisco
    Posts
    8,935
    Quote Originally Posted by Oddity View Post
    An update just dropped a few minutes ago, I wonder if it?s fixed....

    ???????????????

    ...sigh...
    I'm not using iOS. When I have the problem I described earlier, I am using MacOS High Sierra version 10.13.1.

  5. #15
    Senior Member lynnifer's Avatar
    Join Date
    Aug 2002
    Location
    Windsor ON Canada
    Posts
    19,284
    That update yesterday with iphone was supposed to solve the ?'boxed A' problem ... I have a 6 and when it dies, never Apple again!

    Hello Android.
    Roses are red. Tacos are enjoyable. Don't blame immigrants, because you're unemployable.

    T-11 Flaccid Paraplegic due to TM July 1985 @ age 12

  6. #16
    Senior Member Oddity's Avatar
    Join Date
    Oct 2008
    Location
    Virginia Beach, VA
    Posts
    3,161
    Blog Entries
    1
    After more research and experiments, I participate in a number of forum communities, some that also use vBulletin, and I?m only experiencing character encoding issues here. Hmmmmmmmmm....
    "If you only know your side of an issue, you know nothing." -John Stuart Mill, On Liberty

    "Even what those with the greatest reputation for knowing it all claim to understand and defend are but opinions..." -Heraclitus, Fragments

  7. #17
    Senior Member
    Join Date
    Jun 2005
    Location
    East Bay/San Francisco
    Posts
    8,935
    Open some older threads and look at how symbols and/or letters have been corrupted over time. They weren't typed like this originally: http://sci.rutgers.edu/forum/showthr...ht=open+letter
    Attached Images Attached Images  

  8. #18
    Senior Member Oddity's Avatar
    Join Date
    Oct 2008
    Location
    Virginia Beach, VA
    Posts
    3,161
    Blog Entries
    1
    Seem's it's finally been fixed.

    '
    "

    An iOS update came out yesterday but I haven't installed it yet, so something else changed.

    YAY!

    Quote Originally Posted by Oddity View Post
    After more research and experiments, I participate in a number of forum communities, some that also use vBulletin, and I?m only experiencing character encoding issues here. Hmmmmmmmmm....
    -/:;()$&@?.,!?[]{}#%^*+=_\|~<>????.,!?

    Thats every special character from a standard iOS 11.2 English keyboard, except question mark, in order they appear on the keyboard.

    So, most ones not parsing correctly are above ascii 127, so encoding may not be set right on web server or html config files or database server.

    My vote is database since the encoding error doesn?t occur until the text is inserted and then fetched again. Was it switched from UTF recently to save space?

    But I dunno. It is silly though.

    Odd that I can edit the special characters back into the post, that the error only occurs on initial insert, not subsequent updates. That’s a big clue right there!!! (I just edited the apostrophe s on that sentence and it is fine)
    Last edited by Oddity; 01-11-2018 at 10:42 AM.
    "If you only know your side of an issue, you know nothing." -John Stuart Mill, On Liberty

    "Even what those with the greatest reputation for knowing it all claim to understand and defend are but opinions..." -Heraclitus, Fragments

  9. #19
    Senior Member Oddity's Avatar
    Join Date
    Oct 2008
    Location
    Virginia Beach, VA
    Posts
    3,161
    Blog Entries
    1
    '"????

    Well, quotes and apostrophes are fixed, at least!
    "If you only know your side of an issue, you know nothing." -John Stuart Mill, On Liberty

    "Even what those with the greatest reputation for knowing it all claim to understand and defend are but opinions..." -Heraclitus, Fragments

  10. #20
    This version of vBulletin is outdated and unsupported. When we move the site to their cloud and pay them a monthly fee, they will upgrade us to the newest version. I have been out of work for a month. When I return next week, Steven and I will begin planning the transition.

Similar Threads

  1. Movies featuring characters with disabilities
    By Max in forum Ability & Disability News
    Replies: 0
    Last Post: 12-16-2002, 05:07 PM
  2. Characters of CareCure
    By Jeff in forum Life
    Replies: 17
    Last Post: 10-05-2001, 03:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •