Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Windows 10/Microsoft Edge Update

  1. #1

    Windows 10/Microsoft Edge Update

    Anyone notice how slow and staggery Microsoft Edge is after the most recent Windows 10 Update. It was already slower than Chrome before, but now is nearly unusable. My mouse moves across the screen like its wading through molasses. Ridiculous!

  2. #2
    I haven't noticed any problems for me.

  3. #3
    Why wouldn't you just use chrome?

  4. #4
    I only use Edge to get points on my Microsoft Bing accounts. If not for that, I probably would have never noticed.

  5. #5
    Quote Originally Posted by Scott C4/5 View Post
    I only use Edge to get points on my Microsoft Bing accounts. If not for that, I probably would have never noticed.
    I mine my bing points too, but other than that I like edge.

    Have you tried the chrome spoofer and binger extension in chrome to get your bing points ? WAY quicker that way.

  6. #6
    I haven't noticed any performance problems, what are the specs of the machine you are running on? I use chrome mostly but for sites that have implemented adblock deterrents (like forbes.com) I use Edge, also use it for the Azure portal.

  7. #7
    I'm beginning to think that it has something to do with the software for my smartnav headmouse. Edge is working better but its still a little sluggish... actually, since the update, my mouse has been "sticky" on everything.

    McLaren, I'm hesitant to use anything to get my bing points easier. When they had clubbing.com people got their accounts terminated for those sorts of hacks. Also, you get 5 extra daily points for clicking on the "Earn more points" link on non-Edge browsers. Then going to Edge for those extras.

    t8burst, my ACER laptop system consists of the following:
    Windows 10 Home 64bit
    Intel Core i5-6200U dual core 2.30 GHz
    12gb RAM
    Intel HD Graphics 520

    I did a fresh clean install about 6 weeks ago and had no problems prior.

  8. #8
    Senior Member
    Join Date
    Dec 2004
    Location
    Alberta, Canada
    Posts
    7,029
    I had to roll back to an earlier update/whatever. Volume was quiet. It was slow af. I could no longer connect to devices wirelessly.

  9. #9
    Quote Originally Posted by NorthQuad View Post
    I had to roll back to an earlier update/whatever. Volume was quiet. It was slow af. I could no longer connect to devices wirelessly.
    My volume is low too... thought it was related but couldn't see how. But when I checked the restore points, there were none available.

  10. #10
    Apparently the audio problem is a bigger problem than the sluggish mouse trouble that I am having...
    http://www.valuewalk.com/2017/04/fix...udio-problems/

Similar Threads

  1. Replies: 0
    Last Post: 11-14-2016, 01:36 PM
  2. Microsoft PowerToys for Windows XP
    By PN in forum Computers
    Replies: 0
    Last Post: 10-12-2004, 06:25 PM
  3. Microsoft admits new Windows problems
    By Jim in forum Computers
    Replies: 2
    Last Post: 09-10-2003, 08:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •