Results 1 to 3 of 3

Thread: Permobil m300 squeaking actuators

  1. #1

    Permobil m300 squeaking actuators

    The actuators on my m300 make a squeaking / squealing sound when I tilt or recline. The leg elevator doesn't make any noise. But the other two actuators have started to squeal in the last few months. It's kind of annoying. Has anyone I had this issue and what were you able to do to fix it?

  2. #2
    Senior Member Timaru's Avatar
    Join Date
    Apr 2006
    Location
    Hampshire, England.
    Posts
    5,004
    A good squirt of silicone spray stops mine squeaking (Invacare Storm 4).
    Last edited by Timaru; 09-27-2016 at 10:57 AM.

  3. #3
    Do the Pistons that move in and out of the tilt actuators on the base get lubricated? I was told that they don't. It always seems to me that they should however.

Similar Threads

  1. Ram Mounting Options for Permobil M300
    By rabidsquirrel in forum Equipment
    Replies: 0
    Last Post: 08-27-2015, 03:29 PM
  2. Permobil m300 ps questions reviews
    By mikeyb in forum Equipment
    Replies: 0
    Last Post: 10-17-2014, 04:00 PM
  3. Permobil M300 question
    By Ephraimh in forum Equipment
    Replies: 3
    Last Post: 10-10-2012, 10:27 AM
  4. My Permobil M300 3G is in the shop
    By SCIfor55+yrs. in forum Equipment
    Replies: 24
    Last Post: 09-10-2012, 03:32 PM
  5. My M300 Permobil arrived
    By SCIfor55+yrs. in forum Equipment
    Replies: 35
    Last Post: 07-10-2012, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •