Results 1 to 7 of 7

Thread: Permobil C500 Left Wheel Locked - Short in Motor????????????

  1. #1
    Senior Member
    Join Date
    Jul 2010
    Location
    Pennsylvania
    Posts
    194

    Permobil C500 Left Wheel Locked - Short in Motor????????????

    Okay, need some advice here - again.

    We just replaced the 2 MK batteries in the C500 Permobil about a month ago. We have been very careful to not overcharge the new batteries. Once they were fully charged we only charge when it's in the yellow. Today spontaneously the meter on the joystick went clear down into the yellow. After about 5-10 minutes the meter went back up into the green and everything worked as it is supposed to.

    We were getting ready to go to bed with the chair on, and when Danny tried to turn and go a different direction, all he could do was go in circles. The left front wheel locked. At the same time the meter went clear down into the yellow and then into the red. We turned it off and then back on and now the last two red bars are flashing red. At first you could hear the electronic brake clicking on and off, but now nothing. The elevator and tilt still work, but the chair will not move. We tried putting it in neutral and back, and also tried turning the circuit breaker off and on, but it did not help.

    We put it on charge in hopes something will work, but does anyone have any thoughts or suggestions for what might be happening? Could it be a short in the left motor?

    As always, thank you for any help!

  2. #2
    Check pages 76 and 77: http://www.permobilus.com/manuals2/26.pdf
    It says the connection to the right drive motor instead of the left, but I'd check all connections and look for frayed wires. I doubt anything is wrong *inside* a motor.
    I have had periodic paralysis all my life. I lost my ability to walk in 2011 beginning with a spinal block, which was used for a hip fracture caused by periodic paralysis.

  3. #3
    There have been a number of reported problems with the entire wiring harness on some Permobil chairs in the 300, 400, and 500 series. It is most likely due to a problem in your control wiring harness, rather than the motor.

    (KLD)

  4. #4
    Senior Member
    Join Date
    Jul 2010
    Location
    Pennsylvania
    Posts
    194
    Thanks for the replies nonoise and SCI-Nurse. I have printed out those two pages and will give them to Danny. He just had a repairman here last week ($125 just to come to the door because this isn't his primary chair any longer, but life is tough without it!) for the tilt, etc. mechanism, and he is to return to fix that when he has the part. Hopefully he can fix the new problem too. Do you think this is something a person with some electrical know-how could fix? Certainly not me, but I'm sure if Danny couldn't fix it, he might know someone who can fix it sooner rather than later. Thanks again! I will post again when we have figured it out, just in case anyone else can benefit from this experience. It's always an adventure when you love someone with a SCI, sometimes good, sometimes notsogood, but we always try to see the positive in things and laugh whenever we can. Like this time - thank God this didn't happen when he was out in the woods hunting a few weeks ago . . .

  5. #5
    I would say that the motor brake is probably stuck or not getting energized. When you move the joystick the brake unlocks, hence the clicking sound. Can you hear/feel the click on that side when the joystick is moved? First thing to check is the wire connections to the affected side.

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Location
    Houston texas
    Posts
    201
    Try YouTube...always good info on there..
    Louie Gonzalez
    C6 C7

  7. #7
    Senior Member
    Join Date
    Jul 2010
    Location
    Pennsylvania
    Posts
    194
    Just wanted to update . . . the technician took the connections off the motor, made sure it was okay, cleaned the connections and reattached, making sure everything was tight. Now everything works great! Go figure . . . well, he did say we got a GREAT deal on the "spare" Permobil we purchased, and we did learn a thing or two about if this ever happens again. I guess it's all a learning experience (sigh).

Similar Threads

  1. .Permobil C500 w/ESP
    By forestranger52 in forum Equipment
    Replies: 54
    Last Post: 10-10-2015, 05:56 PM
  2. Wanted: Permobil C500 tilt actuator and motor
    By DeadEye in forum Equipment & Services
    Replies: 5
    Last Post: 12-11-2012, 12:38 PM
  3. Permobil C500 VS Yes or No?
    By DogInspired in forum Equipment
    Replies: 4
    Last Post: 12-16-2010, 05:11 PM
  4. Tried out the Permobil C500 VS
    By mxracer86 in forum Equipment
    Replies: 0
    Last Post: 05-19-2010, 11:55 AM
  5. Replies: 5
    Last Post: 10-31-2008, 03:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •