Hello everyone,
I'm having problems with the tilt function on my Invacare TDX SP. Yesterday, I had the seat fully tilted back and when I pushed the button (I use buttons instead of the joystick) to bring the seat down to a level position, nothing happened. I heard the actuator turning but the seat did not move. I asked a neighbor to help me out by pushing down on the foot pedals and that worked, as he pushed down the seat slowly started to level out. Once I had the seat completely out of tilt, I pressed the button again to test if I could tilt the seat just a bit (also, it's a more comfortable position) and it worked. I tilted to chair completely again and my brother looked under under the seat to see if there were any obvious problems. Everything looked fine, the actuator was connected to the subframe that's connected to the bottom of the seat. He tested the tilt function again, going from level to full tilt and back to level again and everything seemed to be okay. However, when I got in the chair this morning and went to tilt the seat, I heard a slight cracking noise and then just the sound of the actuator turning but the seat would not tilt. I haven't been able to get the seat to tilt since then although I do hear the actuator turning both directions.

When my brother was checking the actuator, he said he could hear some rattling inside the long cylindrical part of the actuator that connects to the subframe. Problem is, it looks like the actuator is a sealed unit and not easily serviceable. Is anybody familiar with these units and how hard it might be to repair? Has anybody had a similar problem (or any problem) with the tilt actuator's on their TDX SPs? I ask because this is the 2nd or 3rd tilt actuator I've had to replace on this chair in the past 2 years. I'm supposed to be getting a new chair next week so I'm not sure if Medicare will even pay for a new actuator for this chair. Thing is, I'd like to have this chair as a backup and would like to have the tilt function operational even if it meant spending a few $$ of my own to get it fixed.

Thanks in advance for any info y'all can provide!Hello everyone,
I'm having problems with the tilt function on my Invacare TDX SP. Yesterday, I had the seat fully tilted back and when I pushed the button (I use buttons instead of the joystick) to bring the seat down to a level position, nothing happened. I heard the actuator turning but the seat did not move. I asked a neighbor to help me out by pushing down on the foot pedals and that worked, as he pushed down the seat slowly started to level out. Once I had the seat completely out of tilt, I pressed the button again to test if I could tilt the seat just a bit (also, it's a more comfortable position) and it worked. I tilted to chair completely again and my brother looked under under the seat to see if there were any obvious problems. Everything looked fine, the actuator was connected to the subframe that's connected to the bottom of the seat. He tested the tilt function again, going from level to full tilt and back to level again and everything seemed to be okay. However, when I got in the chair this morning and went to tilt the seat, I heard a slight cracking noise and then just the sound of the actuator turning but the seat would not tilt. I haven't been able to get the seat to tilt since then although I do hear the actuator turning both directions.

When my brother was checking the actuator, he said he could hear some rattling inside the long cylindrical part of the actuator that connects to the subframe. Problem is, it looks like the actuator is a sealed unit and not easily serviceable. Is anybody familiar with these units and how hard it might be to repair? Has anybody had a similar problem (or any problem) with the tilt actuator's on their TDX SPs? I ask because this is the 2nd or 3rd tilt actuator I've had to replace on this chair in the past 2 years. I'm supposed to be getting a new chair next week so I'm not sure if Medicare will even pay for a new actuator for this chair. Thing is, I'd like to have this chair as a backup and would like to have the tilt function operational even if it meant spending a few $$ of my own to get it fixed.

Thanks in advance for any info y'all can provide!