Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Low tire pressure light on Braun vans

  1. #1

    Low tire pressure light on Braun vans

    Does anyone else constantly get a low tire pressure warning light on their Braun vans, despite the tire pressure being just fine? Someone told me it's usually a glitchy sensor on the spare tire. Does Braun adapt the spare tire position or is it just like in a regular Toyota? Would a regular dealership be of any help, or is it likely a conversion issue? I've had the same problem on two Braun vans, one a Sienna and the other a Chrysler Town & Country.

  2. #2
    Suspended Andy's Avatar
    Join Date
    Jun 2003
    Location
    Chicago IL
    Posts
    9,722
    Does the van have a display that ID's tire position...or is it generic 'one of them low'? It probably has a dead battery in one of the wheel sensors, requiring a replacement, trick is to figure out which one.

  3. #3
    Senior Member McDuff's Avatar
    Join Date
    May 2004
    Location
    Dallas area, Tx
    Posts
    3,470
    I'm with Andy. My spare is one of those tiny tires and doesn't have a TPS on it.

    If it is like my system, '05 T&C, it doesn't tell you which one, just how many tires are low. So, if you have someone with an air compressor, you could let air out of a tire(I think it takes like 20% loss to show low) and see if your display shows another low tire, then air it back up. The tire that doesn't increase the number would be the one with the dead sensor. Remember to turn the van off after each stage, mine needs a reset to then show current results of sensors.
    "a T10, who'd Rather be ridin'; than rollin'"

  4. #4
    Senior Member
    Join Date
    Jan 2009
    Location
    Baldwinsville, N.Y.
    Posts
    645
    Scraper,
    I have had a Toyota sienna van the last five years and always have that issue. What I did to solve it , was over inflate the tires by five pounds. That solved the light sensor issue. Make sure you balance/rotate ever five thousand if you are running the no flats. I have had good success with them.
    Best Regards,
    Joe

  5. #5
    I had the issue with my Toyota car. I took it to the dealer ship and they changed the batteries in the 4 sensors for about $150. If I know that's all it needed I would have had my normal shop do it for less.


    I only have one light on my dash board. If there are 4 lights on the dash they have to reprogram the computer every your tires are rotated or 4 of the lights will stay on.


    I do not think the smaller spare tires have them, but I could be wrong.

  6. #6
    Gah, sorry, I did not see all these replies.

    It's just the generic "low tire pressure" icon lit up - there's no further info or text.

  7. #7
    Quote Originally Posted by McDuff View Post
    I'm with Andy. My spare is one of those tiny tires and doesn't have a TPS on it.

    If it is like my system, '05 T&C, it doesn't tell you which one, just how many tires are low. So, if you have someone with an air compressor, you could let air out of a tire(I think it takes like 20% loss to show low) and see if your display shows another low tire, then air it back up. The tire that doesn't increase the number would be the one with the dead sensor. Remember to turn the van off after each stage, mine needs a reset to then show current results of sensors.
    well, I feel cheated. my 05 T&C just shows exclamation point, no number. :/

  8. #8
    Senior Member tarheelandy's Avatar
    Join Date
    Jan 2008
    Location
    Athens, Ga
    Posts
    545
    Blog Entries
    2
    My low pressure light comes on in my Sienna often but only in the winter(cold weather contraction, I guess). My right front tire always looks low, no matter how much air I put in it. People are always telling me I need to put more air in my front tires because they look low. I thought that maybe the added weight of the ramp conversion to the Sienna might be messing up my tire pressure, so I called Braun and they said that DOT says the converted van has to weigh the same as a non-converted Sienna so they take stuff off of the van to compensate for the conversion. All I know is the front always looks low (even with correct pressure) and my light comes on a lot in the winter!

  9. #9
    Senior Member McDuff's Avatar
    Join Date
    May 2004
    Location
    Dallas area, Tx
    Posts
    3,470
    Quote Originally Posted by cass View Post
    well, I feel cheated. my 05 T&C just shows exclamation point, no number. :/
    Do you have the overhead display where the outside temp and other things show up? It tells you how many in that display.
    "a T10, who'd Rather be ridin'; than rollin'"

  10. #10
    Check the spare wheel, I have the same problem on my Toyota and it was the spare wheel that was causing the problem. Once they pumped up the spare wheel the problem was gone
    edit I just saw the post that you dont have tps
    C5/C6 Complete since 08/22/09

Similar Threads

  1. How important is tire pressure really?
    By nauticalmike in forum Equipment
    Replies: 52
    Last Post: 11-16-2012, 06:16 PM
  2. 2005 toyota LE Braun rampvan XT light blue for sale for $18,000
    By taester00 in forum Equipment & Services
    Replies: 2
    Last Post: 08-31-2012, 03:54 PM
  3. High-pressure clincher tire?
    By kirkwood in forum Equipment
    Replies: 6
    Last Post: 09-06-2008, 09:27 AM
  4. Blinking light on Braun Lift
    By paramoto in forum Equipment
    Replies: 5
    Last Post: 12-26-2007, 05:37 PM
  5. Tire Pressure?
    By Jadis in forum Equipment
    Replies: 9
    Last Post: 10-06-2005, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •