Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Permobil problem

  1. #21
    GotWheels Heres where I posted about my Permobil chair going in and out on me.

    http://sci.rutgers.edu/forum/showthread.php?t=125497

    my dme said its also partly because I have a swing away joystick and it stresses the cables a lot. I'm not sure what to believe but lately its not acting up as much as it had been. So, I haven't gotten a new cable yet. More $$ to spend.......

  2. #22
    I had this same problem on this 500. I'd be flying down the road and it'd stop then start again throwing me back into seat. Kinda fun for awhile, but annoying. They replaced a module and all is good. So when they say it's a loose cable, bad joystick or loose connection for the 100th time tell them to replace the module.

  3. #23

    Permobil C300

    I have been having the very same problems with my C300. Except mine works just fine for about 2 weeks or so after everything has been disconnected & reconnected. Then it just starts up again with the starting/stopping/starting constantly. I have had the main cable replaced and have a new joystick. It hasn't done it for a few days but given time I know it will. I also have another huge problem...my batteries do not last anymore. I cannot even get a half day out of them. Anyone have any ideas? I'm taking my charger to work with me tomorrow so I can charge up over lunch. I just recently got the new joystick thinking it was a problem with it. Also, when the battery gauge is on red and blinking, it only takes about 3 hours to fully charge. This cannot be right, it should be at least an eight hour charge. I just had the batteries replaced earlier this summer.
    c5-6 doi 3-17-99

    "Do or do not. There is no try."
    ~Yoda

  4. #24
    I had the stop/go problem but after going through everything it came up to be the lever to make it freewheel was corroded. After it was replaced it ran fine.
    John-B

  5. #25

    Unhappy

    I have had this problem with my C300, and also with my Pride Legend scooter. It is intermittent. The chair/scooter may go weeks or even months with no problem, then all of a sudden the motors will stop and almost instantly start up and go again. This can be a problem when going down a steep ramp, or when in a store causing those behind to stumble into me. It is a problem for many: there is a thread on the Wheelchairjunkie forum about this. I'm pretty sure it is not the brakes or wiring. The brakes on my Permobile C300 are very loud so I would hear them if they were engaging. It feels like the current is momentarily cut off from the motors, then it almost instantly comes back on. My guess is that it is the module. I build and fly large electric powered RC airplanes and in the past I have experienced this problem with faulty speed control modules. Funny thing is, with my C300, the problem might disappear for weeks or even months, then when I start thinking that it has healed itself, all of a sudden it does it again!

  6. #26
    I had the same problem on my Q6000 and it was the connections to an overload breaker. Because of lose factory connections, the terminals started corroding, heating up and tripping the overload, and than it reset as soon as it cooled down. Once I cleaned and tightened the terminals the problem disappeared.
    Some of those Permobils have the same PG controlers as the Q6000.
    _ _ _ _ _ _ _ _ _
    Jesus said to him, “I am the Way, and the Truth, and the Life. No one comes to the Father except through me." -John 14

  7. #27
    Hello, I have a permobil c400, my chair began randomly stopping instantly whilst i am driving along, mometarily stopping the chair nearly launching me out(its as if i were to take my hand off the controller and two seconds latter put it back. The lights stay solid during this.)

    I called my tech out and he determined it was the tilt mechanism cable ( as it was nearly pulled out from the tilt buttons, seemed to be nearly disconnected.) SO i FINALY after two months get a replacement cable.. It was fine for two weeks and all of the sudden today it does the same thing

    Any help would be AMAZING. Thanks ,MAtt!

  8. #28
    Senior Member jschism's Avatar
    Join Date
    Aug 2010
    Location
    illinois, and no, chicago is not anywhere near where i live
    Posts
    2,167
    Quote Originally Posted by eventhorizzon View Post
    Hello, I have a permobil c400, my chair began randomly stopping instantly whilst i am driving along, mometarily stopping the chair nearly launching me out(its as if i were to take my hand off the controller and two seconds latter put it back. The lights stay solid during this.)

    I called my tech out and he determined it was the tilt mechanism cable ( as it was nearly pulled out from the tilt buttons, seemed to be nearly disconnected.) SO i FINALY after two months get a replacement cable.. It was fine for two weeks and all of the sudden today it does the same thing

    Any help would be AMAZING. Thanks ,MAtt!
    I have a c400 stander that had sporatic electrical problems. In the first year it spent 4 months of that out to be repaired. permobil customer service sucks, I had a factory service guy come out twice , replaced various parts, and it was sent back to factory after that. Still was never fixed and they didn't seem to care and offered no apologies or anything. My DME took it for 2 months and finally permobil replaced all the controllers and wiring harnesses. good luck!
    Oh, their first thought was it was the seat elevator or tilt mechanisms.

Similar Threads

  1. Permobil Problem
    By stuck1 in forum Equipment
    Replies: 6
    Last Post: 11-09-2008, 09:20 PM
  2. Replies: 5
    Last Post: 10-31-2008, 03:00 PM
  3. Permobil
    By trainman in forum Equipment
    Replies: 12
    Last Post: 03-17-2008, 10:07 PM
  4. Permobil Problem???
    By 490 in forum Equipment
    Replies: 2
    Last Post: 02-16-2008, 11:00 AM
  5. Permobil, Yes or No?
    By kimmyprettyface in forum Equipment & Services
    Replies: 3
    Last Post: 04-12-2004, 06:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •