Results 1 to 5 of 5

Thread: anybody ever work on Wells-Enberg pneumatic hand controls?

  1. #1
    Senior Member McDuff's Avatar
    Join Date
    May 2004
    Location
    Dallas area, Tx
    Posts
    3,490

    anybody ever work on Wells-Enberg pneumatic hand controls?

    We were heading for Houston yesterday in the motorhome. When we stopped at a rest stop about 80 miles out of Dallas, I heard a hissing coming from the control box. Ahh shit. Controls were still working, but the pump was working at about 100% duty cycle, and was only keeping pressure about 60lbs, "full" is 80lbs.

    I took the cover off and feeling around, I found what is either a pinhole leak, or a real tiny missing setscrew hole in the accelerator control valve body, underneath and out of sight.. I could cover with my finger and stop the leak, until pressure got too great, then it would push my finger off. Of course being a saturday afternoon, couldn't get a phone call answered.

    Sat there for awhile, contemplating my navel, and wondering if this was going to go "catastrophic" going down the road. Randa hasn't driven it so we would be stuck(good reason to teach her...).

    I thought well maybe I can slow the leak, by putting duct tape on it and cinching it with a zip tie. At first it did no good, but when I moved the handle back and forth, all of a sudden it sealed almost completely, there must be a vacuum at some point and it sucked the tape in a little?

    We decided to come back home and abort the trip, rather be broken down at/near home. We made it fine, with my patch holding the whole way.

    So; this control valve, "looks" straight forward, a "screw on" end on one side, and 2 tubing connectors on the other. If I take it off, do you think I will be able to get them to send me a part, or are they going to say "this work must be done at an auth dealer"? If I take the part off, and my fix off the part, I won't be able to take it in.
    "a T10, who'd Rather be ridin'; than rollin'"

  2. #2
    Senior Member
    Join Date
    Mar 2002
    Location
    Aiken, SC USA
    Posts
    2,124

    Wells Emberg

    I had conversation with WE last week on a different piece of equipment and they were happy to sell me the parts I needed. I have all the directions necessaary to make the repairs.

    Good luck in your rebuild.
    You C.A.N.
    Conquer Adversity Now

  3. #3
    You should call Wells Engberg (800)642-3628 and discuss the problem with them. If it's an easy fix, they will sell you the parts you need, or if you prefer to have someone else fix it, they call give you a list of dealers/installers in your area.

    Good Luck...

    Joe

  4. #4
    Senior Member McDuff's Avatar
    Join Date
    May 2004
    Location
    Dallas area, Tx
    Posts
    3,490
    Thanks guys,

    I talked to W-E awhile ago, and it seems we could have kept on going. turns out that the "hole" I found is actually a "vent" the regulator uses if some debris gets in it. So maybe me putting that tape on it caused it to pass the debris, and that is why it started working again. The tape didn't seal the hole but maybe disrupted the airflow enough to shake it loose, and the vent sealed itself back up.

    They said it should be fine. We are currently trying to re-schedule our trip. <need a "crosses fingers" smilie here>
    "a T10, who'd Rather be ridin'; than rollin'"

  5. #5
    Senior Member McDuff's Avatar
    Join Date
    May 2004
    Location
    Dallas area, Tx
    Posts
    3,490
    *note to self* Problems never, ever fix themselves dummy!

    We headed back down to Houston on tuesday 2/3. We made to the loop down there, and my MH started "dragging down", kept having to give more gas, finally wide open and still slowing down. Made a mad dash to the shoulder and opened my window, whoosh a big cloud of burned brake smell came rolling in. shit!

    When they cooled enough, we limped onto the campground only 5 miles away, with a clunking sound come from 1 wheel. The next morning, after finding out that no mobile mechanic would come to work on brakes in the field, I called my roadside service and arranged a tow. If anyone ever needs a service for a rv(your cars are included), I HIGHLY recommend Coach-Net Service. They pick the tow co. and place to take it to, ad both were great. The tow driver from Apple Towing in Houston, arrived in this beautiful triple axle tow truck and did everything right in hooking up and getting the rig to Cummins Coach Care shop, 30 miles away. The $405 tow bill went straight to Coach-Net, free for me.

    We got to dry camp in the parking lot(the next 2 nights) and had to be out of the rv at 7:30am so the could roll it back in the bay for work. Well, I did hundreds of dollars of damage to the brakes, but after waiting on parts, they got us fixed friday afternoon. Yeehah, let's go to the coast.

    Drove about 60 miles from NE Houston, to outside the SW corner, and WHAM, the brakes locked up and luckily was able to get over again. @#$% Heard hissing from the handcontrols again and opened them up. This time the brake regulator was hissing. Everytime I would turn the air on for them, the brake pedal would get pushed. We were stuck...

    Randa said, I'll try driving. Se we swapped and I positioned my w/c in between the 2 front seats to help out. She drove the remaining 50 miles, on back roads to the campground, the last half at night. She did great, for corners, I was her spotter, she always wanted to turn too tight, "nope not yet, a little more, more, ok turn". She had never even towed anything before, much less drive the MH towing our van, so this was expected, we were 65ft long. And when you tow a car 4wheels down, you cannot backup, even a little, so making it first shot is critical.

    She had to drive the 350 miles home too, thru rain, construction, Interstate 45, and rush hour in Dallas. We broke it up to 2 days to make it easier, camping in College Station half way home. She learned "under fire" ad handled it like a trooper. Now we know she can drive if/when we need.

    A friend works in the valve business and he is sending me the parts to fix the regulators. He sent pics, and there is only a diaphragm and a spring in each, so new 'phrams should fix me up. I never should have restarted the trip.

    We took a couple pics down there, gonna post in Pics Forum.
    "a T10, who'd Rather be ridin'; than rollin'"

Similar Threads

  1. Getting back on SSDI
    By cass in forum Work, School, & Money
    Replies: 57
    Last Post: 11-04-2008, 12:19 AM
  2. Wiped out by the wait
    By Max in forum Ability & Disability News
    Replies: 0
    Last Post: 06-01-2003, 10:39 AM
  3. Keeping people with MS in work
    By antiquity in forum Ability & Disability News
    Replies: 0
    Last Post: 02-23-2003, 08:21 PM
  4. Replies: 0
    Last Post: 11-06-2001, 12:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •